华为交换机如何实现共享带宽(MQC & SuperVlan)

原理:

    1:创建单独的vlan,
    2:并将所需要共享带宽主机的交换机连接端口加入该vlan,
    3:对该vlan进行限速
    4:对共享的口子进行traffic policy的应用
    5:将该vlan作为subvlan加入网关vlan(supervlan)

交换机配置如下

#创建一个超级vlan,并将vlan100加入该supervlan
vlan 3501
 description Gateway
 aggregate-vlan
 access-vlan 100
#
vlan 100

#网关配置在supervlan上,(supervlan能合理利用IP地址)
interface Vlanif3501
 ip address 103.59.42.1 255.255.255.128
 ip address 103.59.42.129 255.255.255.128 sub

#创建流分类,应用到vlan100上
traffic classifier vlan100 operator and
 if-match vlan-id 100
traffic classifier all operator and
 if-match any

#创建流行为
traffic behavior P100M
 car cir 102400 pir 102400 cbs 12800000 pbs 12800000 green pass yellow pass red discard
 statistic enable

#创建流策略,匹配流行为流分类
traffic policy GW-UPlink
 classifier vlan100 behavior P100M
 classifier all behavior all
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 100
 traffic-policy GW-UPlink inbound
 traffic-policy GW-UPlink outbound
#
interface GigabitEthernet0/0/4
 port link-type access
 port default vlan 100
 traffic-policy GW-UPlink inbound
 traffic-policy GW-UPlink outbound
微信打赏微信打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者

最后编辑于:2022/11/26作者: 辣条①号

现在在做什么? 接下来打算做什么? 你的目标什么? 期限还有多少? 进度如何? 不负遇见,不谈亏欠!

暂无评论

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注

arrow grin ! ? cool roll eek evil razz mrgreen smile oops lol mad twisted wink idea cry shock neutral sad ???